Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Daniel Paschek
    Participant
    Post count: 6

    Hi,

    I’m trying to tab the frequencies of Countries (stored as string) in my dataset with Asdocx.
    However, I receive the error “option Data not allowed” – does anybody know how to fix this?

    Also, how can I use commas in my number format, e.g. 1,000 instead of 1000.

    Thanks!

    Dr. Attaullah Shah
    Keymaster
    Post count: 106

    Daniel, please post data example using the dataex command so that I can replicate the problem at my end. If dataex is not installed, then you can install it from the SSC/

    ssc install dataex
    dataex
    Daniel Paschek
    Participant
    Post count: 6

    For simplicity, I used the auto dataset

    The following code gives me the same error

    clear
    sysuse auto
    (1978 Automobile Data)
    asdocx tab make, save(Example.docx) replace
    

    Then I get this message:
    option Data not allowed
    r(198);

    Hope this makes it clear. In an related issue, how would I format the number like posted early (e.g. 1,000 vs 1000)?

    Dr. Attaullah Shah
    Keymaster
    Post count: 106

    Please update asdocx and re-try.

    asdocx_update
    

    The string issue should be solved. For reporting comma separators with thousands, use the option spe000. See example

    sysuse auto, clear
    asdocx sum, sep000 replace
    

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.